Repairs to the fiber cut outside the Temple regeneration site have been successfully completed, and services in the Salado area have been fully restored.
If you are still experiencing any service issues, please contact Nexstream Customer Care by texting 830-990-1118, and a team member will assist you promptly.
We appreciate your patience and understanding.
Posted Apr 15, 2025 - 06:38 CDT
Update
Construction crews are currently working on the damaged site.
Posted Apr 14, 2025 - 20:22 CDT
Update
Our carrier has identified the damage and is strategizing repairs.
Posted Apr 14, 2025 - 19:35 CDT
Update
Carrier technicians ETA is currently estimated to be 6:30pm CST. We will keep you posted for updates.
Posted Apr 14, 2025 - 17:40 CDT
Identified
We’ve identified a fiber cut alarm just outside the Temple regeneration site, which is currently impacting services in the Salado area. Nexstream’s Network Operations and Outside Plant (OSP) teams are actively engaged in the restoration process, with repair crews en route to assess the damage and begin necessary repairs.
Our Customer Care team is closely monitoring the situation and will provide updates as new information becomes available. For the latest service status, please visit our Network Status Page at http://status.nexstream.net.
Posted Apr 14, 2025 - 16:45 CDT
Investigating
We are currently investigating this issue.
Posted Apr 14, 2025 - 15:19 CDT
This incident affected: High-Speed Internet (Gig+ Fiber).