As of 8 PM, Nexstream crews have completed the splicing of an auxiliary fiber line to restore service for most impacted subscribers. Work remains ongoing to isolate additional impacts and permanent repair/replacement of the impacted fiber mainline.
If your connectivity has not been automatically restored, please attempt to power-cycle your fiber terminal and router by unplugging power to each device and waiting at least 5 minutes before plugging it back in. If you are still offline after power-cycling your equipment, please text your name and service address to Customer Care at 830-990-1118.
Nexstream will continue to work for resolution until connectivity has been restored for all subscribers and will post additional updates as they become available. For the latest, please visit and subscribe to our network status page at http://status.nexstream.net.
Posted Nov 01, 2023 - 20:48 CDT
Identified
Customers in the Spicewood area are currently experiencing an outage. Fiber infrastructure serving communities in this area was damaged during road maintenance. Nexstream crews have been deployed for repair.
Please subscribe to the status page for updates by text or email for updates on estimated time of restoration.
Posted Nov 01, 2023 - 09:31 CDT
This incident affected: High-Speed Internet (Gig+ Fiber).