Service Interruption

Incident Report for Nexstream Services

Resolved

Service has been restored to customers at FireFly Resort following the CTEC power outage.

Our network operations team has confirmed services are back online and operating normally.

We appreciate your patience and understanding while service was impacted.
Posted Aug 27, 2026 - 18:12 CDT

Identified

We are currently aware of a service disruption affecting customers at FireFly Resort due to a CTEC power outage. Our network operations team is monitoring the outage and will restore service as soon as power is restored.

We recognize the inconvenience this may cause and appreciate your patience.

For ongoing updates, please visit http://status.nexstream.net and subscribe for notifications via text or email.

We will continue to share updates as more information becomes available.
Posted Aug 27, 2026 - 17:27 CDT
This incident affected: High-Speed Internet (Community WiFi).