Emergency maintenance has been completed and connectivity restored to all customers. We apologize for the inconvenience and appreciate your understanding.
Posted Mar 25, 2026 - 18:54 CDT
Update
Restoration efforts continue in earnest as multiple crews remain on-site, focused on completing the final stages of repair. Splicing operations are ongoing, with crews working through the final splice case needed to fully restore the network.
We are seeing continued improvement, with network alarms beginning to clear and services progressively coming back online as this final phase moves forward. Based on current progress, the estimated time for full service restoration remains between 6:00 PM and 7:00 PM CT.
All resources remain fully engaged, and our teams are working as fast as possible to complete the remaining work and restore all services.
We recognize the impact this outage has had and truly appreciate your patience and understanding throughout the restoration process.
For the latest updates, please visit http://status.nexstream.net and subscribe to receive notifications via text or email.
– Nexstream Network Operations
Posted Mar 25, 2026 - 16:22 CDT
Update
Overnight, restoration efforts made substantial progress as multiple crews worked around the clock to address the extensive fiber damage near Temple. The outage was caused by a third-party excavation contractor who struck multiple fiber lines without completing required utility locates. There were no 811 locate markings present at the site. Following the incident, the contractor removed license plates and identifying markings from their vehicles and equipment before abandoning the scene. This matter has been escalated to the appropriate authorities and is currently under investigation.
All cable replacement, rerouting, and preparation work has now been completed. Crews have transitioned fully into the splicing phase, which is actively underway across the affected fiber lines. Based on current progress, we expect customers to begin seeing service restoration this morning as splicing continues.
Multiple splice and underground crews remain on-site working to complete final connections and restore full service as quickly as possible.
We understand the significant impact this outage has had and sincerely appreciate your continued patience as our teams work diligently to restore service.
For the latest updates, please visit http://status.nexstream.net and subscribe to receive notifications via text or email.
We will continue to provide updates as more information becomes available.
– Nexstream Network Operations
Posted Mar 25, 2026 - 07:20 CDT
Identified
The Network Operations team has confirmed the root cause of the service disruption affecting customers in the Salado area. The outage is the result of a major fiber cut near Temple impacting the regional network.
Field crews are on-site and actively working to repair the fiber and restore service as quickly as possible. At this time, there is no estimated time for restoration (ETR). Our team is closely monitoring repair progress and will continue to provide timely updates.
We understand the inconvenience this outage may cause and sincerely appreciate your patience.
For the latest updates, please visit http://status.nexstream.net and subscribe to receive notifications via text or email.
We will continue to share updates as more information becomes available.
Posted Mar 24, 2026 - 20:54 CDT
Investigating
We are currently aware of a service disruption affecting customers in the Salado area, including those near Armstrong Loop. Our network operations team is actively investigating the issue and working to restore service as quickly as possible.
We recognize the inconvenience this may cause, especially at the end of the workday, and we appreciate your patience.
For ongoing updates, please visit http://status.nexstream.net and subscribe for notifications via text or email.
We will continue to share updates as more information becomes available.
Posted Mar 24, 2026 - 18:36 CDT
This incident affected: High-Speed Internet (Gig+ Fiber).