Emergency maintenance has been completed and connectivity restored to all customers. We apologize for the inconvenience and appreciate your understanding
Posted Jun 03, 2026 - 18:33 CDT
Update
The Network Operations team has confirmed that the service disruption affecting customers in the Salado area is the result of a fiber cut impacting an upstream carrier that provides connectivity into the region.
Field crews from the upstream provider are actively working to repair the damaged fiber and restore service as quickly as possible. At this time, there is no estimated time for restoration (ETR). Our team remains in close contact with the carrier and is closely monitoring repair progress.
We understand the frustration that repeated fiber-related outages can cause and sincerely appreciate your patience. To improve network resiliency, Nexstream is currently in the final stages of deploying a completely diverse secondary path into the Salado area through a separate provider. This additional route is expected to be completed by the end of the month and will provide greater redundancy for customers in the event of future upstream disruptions.
For the latest updates, please visit http://status.nexstream.net and subscribe to receive notifications via text or email.
We will continue to share updates as more information becomes available.
Posted Jun 03, 2026 - 15:25 CDT
Identified
The Network Operations team has confirmed the root cause of the service disruption affecting customers in the Salado area. The outage is the result of a major fiber cut near Temple impacting the regional network.
Field crews are on-site and actively working to repair the fiber and restore service as quickly as possible. At this time, there is no estimated time for restoration (ETR). Our team is closely monitoring repair progress and will continue to provide timely updates.
We understand the inconvenience this outage may cause and sincerely appreciate your patience.
For the latest updates, please visit http://status.nexstream.net and subscribe to receive notifications via text or email.
We will continue to share updates as more information becomes available.
Posted Jun 03, 2026 - 10:19 CDT
Investigating
We are currently aware of a service disruption affecting customers in the Salado area. Our network operations team is actively investigating the issue and working to restore service as quickly as possible.
We recognize the inconvenience this may cause and we appreciate your patience.
For ongoing updates, please visit http://status.nexstream.net and subscribe for notifications via text or email.
We will continue to share updates as more information becomes available.
Posted Jun 03, 2026 - 09:15 CDT
This incident affected: High-Speed Internet (Gig+ Fiber).