Internet Outage (Salado)

Incident Report for Nexstream Services

Resolved

We are currently seeing this as resolved.

For connectivity issues, please contact our service desk at 830-990-1118.
Posted Jun 16, 2025 - 16:45 CDT

Monitoring

We are currently seeing clients as reconnected, and our NOC is currently monitoring the situation.
Posted Jun 16, 2025 - 13:02 CDT

Investigating

We are currently investigating this issue.
Posted Jun 16, 2025 - 11:45 CDT
This incident affected: High-Speed Internet (Gig+ Fiber).