CTEC Disruptions (Fredericksburg, Hidden Springs)

Incident Report for Nexstream Services

Resolved

We are currently seeing power restoration through CTEC.

Please contact us at 830-990-1118 if you are experiencing connectivity issues.
Posted Nov 12, 2025 - 15:47 CST

Identified

The issue has been confirmed as a CTEC disruption.
Posted Nov 12, 2025 - 09:20 CST

Investigating

Members of our Hidden Springs fiber community are currently experiencing connectivity issues related to CTEC service disruptions in the area.

Our NOC is actively monitoring the situation.
If connectivity issues persist after power is restored in your area, please contact our service desk at 830-990-1118 for assistance.
Posted Nov 12, 2025 - 09:20 CST
This incident affected: High-Speed Internet (Gig+ Fiber).