CTEC Disruptions (Fredericksburg, Hidden Springs/Frieden)

Incident Report for Nexstream Services

Resolved

We are currently seeing this as resolved.

If connectivity issues have persisted after power is restored in your area, please contact our service desk at 830-990-1118 for assistance.
Posted Mar 07, 2025 - 23:57 CST

Identified

Members of our Frieden/Hidden Springs fiber communities are experiencing connectivity issues related to CTEC service disruptions in the area.

Our NOC is actively monitoring the situation.

If connectivity issues persist after power is restored in your area, please contact our service desk at 830-990-1118 for assistance.
Posted Mar 07, 2025 - 19:13 CST
This incident affected: High-Speed Internet (Gig+ Fiber).