6/24/2025 - Hidden Springs outage

Incident Report for Nexstream Services

Resolved

We are currently seeing this as resolved.

Please contact our service desk at 830-990-1118 if you are still experiencing connectivity issues.
Posted Jun 24, 2025 - 11:40 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2025 - 10:23 CDT

Investigating

We are currently investigating this issue.
Posted Jun 24, 2025 - 09:00 CDT
This incident affected: High-Speed Internet (Gig+ Fiber).