The scheduled maintenance is complete and connectivity restored. If your Internet is not working, please power cycle your fiber ONT, router, and WiFi APs. The Nexstream helpdesk is available to assist from 8am-8pm by texting 830-990-1118.
Posted Dec 13, 2024 - 01:30 CST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 12, 2024 - 23:59 CST
Scheduled
Service impacting maintenance is scheduled for tonight (12/12) from 11:59pm to 6:00am (12/13). Connectivity in the Spicewood service area will be intermittently impacted during this time.
Starting: 11:59pm (Night of December 12th) Ending: 6:00am (Morning of December 13th)
For connectivity issues outside of this timeframe, please contact our support team by text at 830-990-1118.
Posted Dec 12, 2024 - 12:00 CST
This scheduled maintenance affected: High-Speed Internet (Gig+ Fiber).