Internet Outage (Salado)

Incident Report for Nexstream Services

Resolved

We are currently seeing this as resolved.

Please contact our support team by text at 830-990-1118 for any remaining connectivity issues.

Thank you.
Posted Nov 13, 2025 - 22:52 CST

Update

Splicers have finished preparations, and fiber splicing is underway.
Posted Nov 13, 2025 - 21:15 CST

Update

Construction crews are currently actively pulling fiber for repairs.
Posted Nov 13, 2025 - 17:15 CST

Update

Fiber carrier has identified the break as a fiber mainline cut by a utility in the Temple area.
ETR has been requested and our NOC is awaiting updates.
Posted Nov 13, 2025 - 16:07 CST

Identified

Fiber carrier has identified a potential fiber cut and has dispatched technicians.
We will keep you posted for updates as the situation develops.

-Nexstream NOC
Posted Nov 13, 2025 - 14:19 CST

Investigating

We are currently investigating this issue.
Posted Nov 13, 2025 - 13:31 CST
This incident affected: High-Speed Internet (Gig+ Fiber).