Our technician has completed work, and we are currently seeing this as resolved.
Please contact our customer support line by text at 830-990-1118 if you are still experiencing connectivity issues.
Posted Sep 15, 2025 - 13:43 CDT
Identified
We are aware of a localized fiber impact/cut in Salado that is affecting a couple homes. This damage is the result of digging without calling 811 for utility locates beforehand.
✅ Our first available splice crew has been assigned and working to remediate the issue as quickly as possible.
⏱ Estimated time for repair: 12:00 PM on Monday, September 15.
⚠️ A friendly reminder: Always call 811 before you dig, and please encourage your neighbors to do the same. This simple step helps prevent service disruptions and keeps our community connected.
We appreciate your patience while we work to restore service.
— Nexstream Network Team
Posted Sep 14, 2025 - 12:43 CDT
This incident affected: High-Speed Internet (Gig+ Fiber).