Limited LTE connectivity in Llano
Incident Report for Nexstream Services
Resolved
We are currently seeing this issue as resolved.

Please contact our support team at 830-990-1118 if your issues have persisted.
Posted Jul 18, 2024 - 15:52 CDT
Investigating
We've been informed that there are currently connectivity issues with Llano's main cellular towers that our carrier is working to resolve.
Posted Jul 18, 2024 - 10:44 CDT
This incident affected: Nexstream 360 (WiFi / Parental Controls).