Salado - Partial outage (Armstrong Loop)
Incident Report for Nexstream Services
Resolved
This incident has been resolved.
Posted Jan 02, 2025 - 17:08 CST
Identified
Our fiber crew is on-site today for repairs in Salado.
Posted Jan 02, 2025 - 09:43 CST
Investigating
Our team is currently investigating.
Posted Jan 01, 2025 - 07:56 CST
This incident affected: High-Speed Internet (Gig+ Fiber).