Internet Outage (Salado)

Incident Report for Nexstream Services

Resolved

We are currently seeing this incident as resolved, with all Salado clients as online.
Posted Jul 18, 2025 - 08:09 CDT

Monitoring

The repair has been made and we are monitoring the results here.
We are currently seeing clients as reconnected and monitoring for stability.
Posted Jul 18, 2025 - 00:31 CDT

Update

Work will continue well into the night.
Please stay posted for updates.
Posted Jul 17, 2025 - 21:27 CDT

Update

Splicers have uncovered further damage to fiber lines.
Repairs are still ongoing.
Posted Jul 17, 2025 - 19:38 CDT

Update

Splicers have been working on repairs.
This major damage to a mainline, which will take some time for splicing crews.
Posted Jul 17, 2025 - 18:09 CDT

Update

Splicers are working on repairs with crews as of 4:56pm.
Please stay posted for updates.
Posted Jul 17, 2025 - 17:15 CDT

Update

Splicer is on-site narrowing down scope of damage.
Construction crew is 10 minutes out for repairs.
Posted Jul 17, 2025 - 16:06 CDT

Update

This is confirmed to be part of a major upstream outage.
Field dispatch has been created, currently pending ETA for repair crews.
Posted Jul 17, 2025 - 13:41 CDT

Identified

Our team has identified an upstream fiber issue as the source of the outage.
We are presently working on procuring an ETR.

Please stay posted for updates.
Posted Jul 17, 2025 - 12:40 CDT

Investigating

We are currently investigating this issue.
Posted Jul 17, 2025 - 11:28 CDT
This incident affected: High-Speed Internet (Gig+ Fiber).