Fiber outage: Spicewood area
Incident Report for Nexstream Services
Resolved
PEC has restored power to the area and network connectivity has returned.

If you are still experiencing connectivity issues call/text us at 830.990.1118.
Posted May 07, 2024 - 14:40 CDT
Identified
Some customers in Spicewood are currently experiencing a service disruption due to a power outage. We are working to identify the problem and restore connectivity.

Please subscribe to the status page for updates by text or email
Posted May 07, 2024 - 11:23 CDT
This incident affected: High-Speed Internet (Gig+ Fiber).