Nexstream tower maintenance (Wideband, Fredericksburg)

Incident Report for Nexstream Services

Resolved

Repairs were completed at approximately 3:50pm.
Posted Mar 10, 2025 - 16:11 CDT

Investigating

We will be conducting maintenance on one of our towers at this time.
2:50pm-3:50pm

Customers may see a slight interruption of service as repairs begin.
Posted Mar 10, 2025 - 14:48 CDT
This incident affected: Nexstream 360 (WiFi / Parental Controls).