Salado Maintenance Overrun - Connectivity Impact in Armstrong Loop Area

Incident Report for Nexstream Services

Resolved

OSP Crew isolated and resolved the maintenance overrun issue at approximately 7:33 am this morning.
Nexstream NOC monitored for stability throughout the day. No further issues.
Posted Jan 13, 2026 - 17:00 CST

Identified

Nexstream is currently experiencing a service interruption affecting some customers in the Armstrong Loop area between Salado and Holland. This issue is related to an upstream carrier maintenance overrun.

Crews remain onsite and are actively working to restore service as quickly as possible. Some customers have already been restored, though others may still be experiencing an outage at this time. An estimated time of complete restoration is not yet available.

We understand the inconvenience this may cause and appreciate your patience while repairs are completed. Additional updates will be shared as more information becomes available.

Thank you for your understanding,
Nexstream Network Operations
Posted Jan 13, 2026 - 07:17 CST
This incident affected: High-Speed Internet (Gig+ Fiber).