Salado - Partial outage (Armstrong Loop)
Incident Report for Nexstream Services
Resolved
We are currently seeing this as resolved.

Please contact our support team at 830-990-1118 by text if you experiencing further connectivity issues.
Posted Dec 30, 2024 - 20:07 CST
Identified
Technicians have identified the issue and are working on a resolution.
Posted Dec 30, 2024 - 17:48 CST
Update
Technicians have arrived on-site and are actively investigating.
Posted Dec 30, 2024 - 16:48 CST
Update
Technicians are being dispatched. Current ETA is 4:30pm, 12/30/2024.
Posted Dec 30, 2024 - 13:03 CST
Investigating
We are aware of a potential fiber cut impacting some subscribers in the Armstrong loop area, and are dispatching a repair team.
An ETR for repairs will be provided once we understand the extent of the damage.
Posted Dec 30, 2024 - 12:25 CST
This incident affected: High-Speed Internet (Gig+ Fiber).