Nexstream maintenance (Fiber communities) 9/24

Scheduled for Sep 24, 02:00 - 04:00 CDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 17, 2025 - 17:39 CDT

Scheduled

We will be performing routine network maintenance for the following communities from 2-4am cdt Wednesday, September 24th.

Communities:
FireFly
Hidden Springs
Salado

Starting: 2:00 am (Morning of September 24th.)
Ending: 4:00 am (Morning of September 24th.)

If you experience issues outside of this connectivity window, please contact our support desk at 830-990-1118.
Posted Sep 17, 2025 - 17:36 CDT
This scheduled maintenance affects: High-Speed Internet (Gig+ Fiber).