Partial Nexstream Reach 360 Outage
Incident Report for Nexstream Services
Resolved
This incident has been resolved.
Posted Nov 03, 2021 - 17:05 CDT
Update
We are back up! Thank you everyone for your kindness and patience. We are so grateful to be a part of this community!
If you have any additional issues, please send a quick text to 830-990-1118, and we will work to resolve it.
Posted Oct 22, 2021 - 11:49 CDT
Update
We are continuing to investigate this issue.
Posted Oct 22, 2021 - 11:49 CDT
Update
This extended outage impacting some of our customers is directly caused by the Carrier they are connected through. While we continue to apply pressure to expedite restoration of service through the Carrier, we are also working to re-provision impacted LTE Reach subscribers to alternate upstream carriers wherever sufficient coverage and performance is available.

Please know that we share your frustration and are doing everything possible to restore impacted services as quickly as possible.

We encourage you to subscribe at status.nexstream.net to receive update alerts via text/email.

Our Customer Support team can always be reached directly by text/call 830-990-1118 or email help@nexstream.net
Posted Oct 18, 2021 - 09:45 CDT
Investigating
We are currently investigating an issue impacting network performance for some of our Reach 360 customers. The issue is impacting customers sporadically and we are working with directly with our carrier partners to resolve the issue.
Nexstream Customer Service is available and can be reached by phone or text at 830.990.1118 or by email at help@nexstream.net.
Posted Oct 16, 2021 - 12:43 CDT
This incident affected: High-Speed Internet (Reach LTE Wireless).